Texis/Webinator and selinux

Post Reply
User avatar
mark
Site Admin
Posts: 5495
Joined: Tue Apr 25, 2000 6:56 pm

Texis/Webinator and selinux

Post by mark »

By default selinux on Linux will prevent Texis and Webinator from working under Apache. You'll need to enable unconfined access for "texis" in your CGI directory. Something like this:

chcon --type=httpd_unconfined_script_exec_t /var/www/cgi-bin/texis

Typical symptoms of selinux blocking texis are messages like
011 Texis Monitor process failed to create license segment
000 Cannot get config settings
when trying to access with a web browser.

Also look in /var/log/messages or /var/log/audit/audit.log to confirm that it is selinux causing the problem.

You can add the chcon line to the install script if yours doesn't have it. After the line that reads
chmod u+s "$TmpLink"
add
chcon --type=httpd_unconfined_script_exec_t "$TmpLink"
User avatar
mark
Site Admin
Posts: 5495
Joined: Tue Apr 25, 2000 6:56 pm

Texis/Webinator and selinux

Post by mark »

p.s. The above was tested on CentOS 6.0 i686
ebt_13_mgl
Posts: 1
Joined: Mon Mar 12, 2012 10:36 am

Texis/Webinator and selinux

Post by ebt_13_mgl »

i need this program because some document running this program in the internet.
Post Reply