$sourcepath is default Vortex script location for Texis install

Post Reply
Posts: 51
Joined: Wed Jul 10, 2002 6:09 pm

$sourcepath is default Vortex script location for Texis install

Post by nospamjac »

An error like
Texis was unable to process the requested URL:
Check the vortex log
Status: 500 Script not found or Vortex error
means the Vortex script ("dowalk" in this case) is not where Texis expects it to be.

A full Texis distribution comes with Webinator scripts but they are not installed to a useable location because not all Texis buyers want Webinator. To use Webinator the files dowalk, webinatoradmin, and search4 in INSTALLDIR/webinator should be copied to directory INSTALLDIR/texis/scripts/webinator . The .gif files in INSTALLDIR/webinator should be copied to the DOCUMENTROOT/webinator directory. You will have to manually create the 2 "webinator" destination directories mentioned above. INSTALLDIR is where you installed Texis. The default for windows is C:\MORPH3. The default for unix is /usr/local/morph3. DOCUMENTROOT is the directory containing your web documents.

The directory where the scripts are expected to be, INSTALLDIR/texis/scripts, may be customized by editing INSTALLDIR/texis.cnf and changing ScriptRoot (and uncommenting the line by removing the leading ;). To get version 4 behavior of having scripts under the web documents directory use %DOCUMENT_ROOT% for ScriptRoot.

To aid in determining where Texis expects to find its scripts you can edit the INSTALLDIR/texis.cnf file and add
CGI Debug = 1
below the line that reads
;CGI Debug = 0
Then access something like
or (on windows)
and scroll to the bottom where it shows $sourcepath which is the full path to the script it is trying to run.
Remember to turn CGI Debug back off when you're finished poking around.

If you're using vhttpd, its config also has a ScriptRoot setting which will override the texis.cnf value. The vhttpd config is INSTALLDIR/conf/vhttpd.conf .
Post Reply