libncurses.4.so

Post Reply
hfwi
Posts: 2
Joined: Wed Sep 28, 2005 4:45 am

libncurses.4.so

Post by hfwi »

Hi
I have the problem, that i will install the webinator on a linux maschine (Linux cougar 2.4.29-grsec). I downloaded this version of webinator i686-unknown-linux2.4.2-64-32, now i have the problem, that my hoster has the version libncurses.5.so in use.

Is it possible to get a static version of the webinator or what can i to get webinator working ?

Any suggestion are welcome
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

libncurses.4.so

Post by mark »

See the readme at ftp://ftp.thunderstone.com/pub/linux for the necessary libraries. And you'll probably want the "Linux 2.4l2.2 x86" version rather than the "Linux 2.4l2.1 x86". Only exceptionally old systems would use glibc 2.1.
hfwi
Posts: 2
Joined: Wed Sep 28, 2005 4:45 am

libncurses.4.so

Post by hfwi »

I all ready download the necessary file, but i don't have permission to put the file in the /usr/lib folder. And i can't use the command ldd.

I contacted the support of my webhoster, they said, well we have the libncurses.5.so in use, ask they (thunderstone) to provide a static version.

So i don't know what i shall do now. The webinator is a great product, i used several time in other projects, so id would be cool to run webinator on my site.
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

libncurses.4.so

Post by mark »

Sorry there's no static version. Both versions of libcurses can coexist. Some Linux distributions (like redhat for example) even provide those compatibility lib packages that can be installed so software compiled on an earlier system will work. Webinator for Linux 2.4l2.2 runs happily on the latest stock redhat and fedora distributions. It's impossible to compile for every variation of every distribution.
Post Reply