NT & IIS installation in the realworld

cwest
Posts: 7
Joined: Sat Jul 14, 2001 11:39 pm

NT & IIS installation in the realworld

Post by cwest »

I don’t install anything in default locations these days. Check the log file on any NT/IIS box and you’ll see several attempts from outsiders to run cmd.exe. It’s necessary to clearly understand what is to be installed and who should be able to execute and write.

Running your setup.exe and providing server specific locations doesn’t result in a working installation. I’d much rather know precisely as I said before what goes where, permissions, paths, parameters, etc., and install it by hand if there isn’t an install script. Almost every app I install on IIS servers, perl, asp, php, follows this paradigm. Frankly, I’m not interested in setup.exe because it “hides” and assumes too much. If I could read an NT installation, I’d probably soon figure out why I can’t get webinator to work.
bart
Posts: 251
Joined: Wed Apr 26, 2000 12:42 am

NT & IIS installation in the realworld

Post by bart »

Installing the software outside the bounds of setup.exe is not really an option. If you're having a specific problem that is causing the installation to fail from within the context of setup.exe then we'd like to understand and fix it.
cwest
Posts: 7
Joined: Sat Jul 14, 2001 11:39 pm

NT & IIS installation in the realworld

Post by cwest »

OK, I ran setup.exe. The directories are /webinator and /cgi-bin (on this particular server). Browsed to domain.com/webinator and default.html loads. Click on search or newsearch links, and 404.
User avatar
John
Site Admin
Posts: 2600
Joined: Mon Apr 24, 2000 3:18 pm
Location: Cleveland, OH
Contact:

NT & IIS installation in the realworld

Post by John »

You need to make sure that the /cgi-bin directory has execute permissions. Since you have a somewhat non-standard configuration the path in default.html is incorrect, and may need to be:

domain.com/cgi-bin/texis.exe/webinator/newsearch

If the webinator directory is not writable by IUSR_... then you may want to compile the script by hand from the command prompt with

/cgi-bin/texis.exe -C /webinator/newsearch

assuming those are the full-paths to the files.
John Turnbull
Thunderstone Software
Post Reply