Can't create new database

Post Reply
sduggan
Posts: 84
Joined: Tue Mar 20, 2001 9:16 am

Can't create new database

Post by sduggan »

This question is pretty long please bear with me.
I've been trying to create a new database using this string. (Which I have successfully done with two other websites) but now need to do it on the production server:

N:\rsasfiles\Inetpub\betaroot\search\webinator\bin>gw -d/rsasfiles/inetpub/betaroot/search/webinator/newdb -fasp -n"application/pdf,pdf,pdftotx" -k"\alnum{2,30}" -k">>\alnum=[\alnum/]{1,29}" http://website_name

When I do I get this as part of the error message:
++++++++++++++
can't open N:\rsasfiles\inetpub\betaroot\search\webinator\newdb: No such file or directory
Could not connect to /rsasfiles/inetpub/betaroot/search/webinator/newdb
Database created
Can't open N:\rsasfiles\Inetpub\wwwroot\search\webinator\_master\SYSOBJECTS.tbl for read: No such file or directory
+++++++++++++
It then proceeds to create a new folder called newdb with some of the files but not all that are in my original db folder. Especially SYSOBJECTS.tbl.

I then did a gw -wipe -d/ rsasfiles/inetpub/betaroot/search/webinator/newdb
, which gave me the error message:
2001/10/29 09:45:33 Could not find table html
2001/10/29 09:45:33 Could not find table refs
2001/10/29 09:45:33 Could not find table todo
2001/10/29 09:45:33 Could not find table error
2001/10/29 09:45:33 Could not find table options
2001/10/29 09:45:33 Could not find table querylog

and then it proceeded to create some of the missing files into the newdb folder. So I then tried to index the site again using the orignal string again and it looked like it was working indexing my site. But when it was done and I tried to search the database using the string ending in ?db=newbd all my queries came back with saying "No documents matched your query. "

Now one of the peculiar things is the SYSOBJECTS.tbl that got created in my newdb folder has the same date a file size of the SYSOBJECTS.tbl in my orignal db folder but all the other files in that folder had todays date. The folder _master containing SYSOBJECTS.tbl which it keeps looking for is missing from my system.

1. Do I need the _master folder to create new databases?
2. What do I need to do now so I can create a new database to search.

Any help will be greatly appreciated. I've done everything I can think of other than re-installing the software.
Thanks.
Shawn
User avatar
mark
Site Admin
Posts: 5513
Joined: Tue Apr 25, 2000 6:56 pm

Can't create new database

Post by mark »

Yes. You must have _master/SYSOBJECTS.tbl to create databases.

When you perform the search that gets no results but should, view the source of the results page and look for errors/warnings withing HTML comments.
sduggan
Posts: 84
Joined: Tue Mar 20, 2001 9:16 am

Can't create new database

Post by sduggan »

I checked the HTML source and there are no errors. I just get "No documents matched your query. " after doing a search.

How do I get back the _master/SYSOBJECTS.tbl?

I don't want to re-install the application unless absolutely necessary. Can I copy the _master folder from my development server (where it is working) to the server where it isn't?

Thanks
Shawn
User avatar
John
Site Admin
Posts: 2595
Joined: Mon Apr 24, 2000 3:18 pm
Location: Cleveland, OH
Contact:

Can't create new database

Post by John »

Yes, you can copy the _master folder from the dev server (assuming of course it's the same version). You can then copy the SYSOBJECTS.tbl file into the one database that is not searching. Newly created databases will copy if from _master.
John Turnbull
Thunderstone Software
Post Reply