RedHat 7.3 Installation Woes

Post Reply
campbell
Posts: 2
Joined: Tue Jan 14, 2003 11:40 am

RedHat 7.3 Installation Woes

Post by campbell »

Last year, we switched from Tru64 to Linux versions of the Texis product. I installed on a RedHat 7.2 box, but never got the data migrated...and then had to move on to other projects.
I have now updated the box to RedHat 7.3 and use the standard apache install for a web server. I tried to install Texis(Version 4.00) but keep getting CGI environment variable problems. I have two updates to apply after getting Version 4.00 installed.
My install script looks like the following:

===============================================================================
Texis Version 4.00 Installation
===============================================================================

Checking install script...Ok
If you already have full Texis installed you should read the upgrade notes.
View the upgrade notes? (y/n): n
Examining your system...done

------------------------------ NOTE: ---------------------------------
This installation should preferably be run as the user that will
actually run the software, not as root. The user should be the same
user that your web server runs CGI programs as. For this installation
you should have permission to place and move files in the install
directory and the web server tree.

You appear to be root. What (non-privileged) user will be running the
software? Texis files will be owned and setuid to this user. Either:
o Enter the CGI user below, or
o Enter "none" to skip the chown (YOU will have to do it later), or
o Press Ctrl-C/Del to quit, and re-start install as the CGI user.

Web user [ENTER for apache]:

-----------------------------------------------------------------------
What directory would you like to install Texis in? Texis
executables and other files will be placed under here. It should be
OUTSIDE (inaccessible to) your web server tree. NOTE: This directory
should be /usr/local/morph3 unless you are unable to install there.

Install dir [ENTER for /usr/local/morph3]:
Checking install dir...Ok
Checking tar file...Ok
Unpacking Texis files...Ok
Checking files...Ok
Configuring and installing Texis files:
INFO: 1 patch made
INFO: 1 patch made
INFO: 1 patch made
INFO: 1 patch made
INFO: 1 patch made
Existing default database /usr/local/morph3/texis/testdb preserved.
Cleaning up temp files...done

------------------------------------------------------------------------
Will you be:
1) Using an existing web server on this machine?
2) Using the Texis web server (vhttpd) exclusively?

(Enter 1 if you will be using both or,
have a running web server and don't know if you will be using vhttpd)

1 or 2 [ENTER for 1]:

---------------------------------------------------------------------
Where is your web server's CGI directory? This is the full path to
the file system (*not* URL) directory on this machine containing your
CGI programs. Usually this is under the top directory for the web
server. For Apache servers, it is probably the second argument to
ScriptAlias in your conf file.

This installation will install some programs (symlinks) in the CGI
directory you specify. Programs there must be executable by the web
server. The install will verify this with a web fetch.

CGI dir [ENTER for /var/www/cgi-bin]:

-------------------------------------------------------------------------
What is the prefix for CGI URLs (the part of the URL before the program)?
o You may enter a URL, such as http://cnlibrary2.cnpapers.com/cgi-bin
if your site uses virtual hosts or a port other than 80. The site
must reside on this machine (the one running the install).
o Or you can enter just a URL path such as /cgi-bin (assumes host above)
o Or enter /newdir to start over with a new CGI directory instead.

CGI URL prefix [ENTER for http://cnlibrary2.cnpapers.com/cgi-bin]:

---------------------------------------------------------------------------
What is the extension for CGI URLs (the filename extension of the program)?
This may be .cgi if your CGI programs are named like "mysearch.cgi" in URLs.
Or it may be "none" if you have a dedicated CGI dir and URL instead.

CGI extension [ENTER for none]:
Backing up existing /var/www/cgi-bin/texis to /var/www/cgi-bin/texis-old
Stopping monitor processes.....done
Checking dir with a web fetch...Failed
Trying again with file...Ok
Verifying version...Ok
Updating license...done
Verifying variables...*** Failed ***
$urlroot was instead of /cgi-bin/texis/installtest.
$pathroot was instead of /installtest.
Document root dir does not exist.
$sourcepath was .

One or more variables were not set as expected by the URL:
http://cnlibrary2.cnpapers.com/cgi-bin/ ... html?-dump
The web server may not be running Texis for that URL, or it may be
incorrectly setting CGI variables. Netscape-Enterprise/3.6 is known
to have such a bug. Your web server appears to be
Apache/1.3.23 (Unix) (Red-Hat/Linux) mod_ssl/2.8.7 OpenSSL/0.9.6b DAV/1.0.3 PHP/4
.1.2 mod_perl/1.26.

Make sure you are running a web server that sets CGI environment
variables, such as $SCRIPT_NAME, $PATH_TRANSLATED, $PATH_INFO, and
$DOCUMENT_ROOT, correctly. Without them Vortex cannot run correctly
on a web server.

*** Aborting installation due to above error ***

Apache version is RH 1.3.23. I don't recall the problem presenting itself before.

I think ScriptAlias is setup right in httpd.conf.

Are there any known issues with this setup?

Thanks
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

RedHat 7.3 Installation Woes

Post by mark »

Not sure, but if you have updates you should install the latest version, not an old one. Each update is a complete set and does not require previous versions.
campbell
Posts: 2
Joined: Tue Jan 14, 2003 11:40 am

RedHat 7.3 Installation Woes

Post by campbell »

OK, that at least helps. And the problem seems solved.

RedHat creates a user "apache" to run the server. It has no function other than that. I modified the user to be a real user, logged in as 'apache', and the install appeared to be fine.

I'll get back in the event there are other problems.

Thanks
Post Reply