Newbie ?

webmaster1650
Posts: 7
Joined: Mon Sep 29, 2003 5:09 pm

Newbie ?

Post by webmaster1650 »

all files
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

Newbie ?

Post by mark »

No. You are supposed to install somewhere other than cgi-bin. The install will also ask for your cgi directory so that it may place the one needed program there.

I assume you're referring to Webinator. See the installation section of the Webinator manual
http://www.thunderstone.com/texis/site/ ... stallation
webmaster1650
Posts: 7
Joined: Mon Sep 29, 2003 5:09 pm

Newbie ?

Post by webmaster1650 »

yes
webmaster1650
Posts: 7
Joined: Mon Sep 29, 2003 5:09 pm

Newbie ?

Post by webmaster1650 »

i keep getting this message:
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

Newbie ?

Post by mark »

Check your virtual host setup. Find where the proper cgi directory for that site is on disk. Make sure "texis" is there. If it still "doesn't work" please be detailed and tell us what happens when you try it.

"404" errors mean you don't have the right cgi directory.

Having /usr/local/morph3/bin in your PATH is optional but makes using the command line tools easier.
webmaster1650
Posts: 7
Joined: Mon Sep 29, 2003 5:09 pm

Newbie ?

Post by webmaster1650 »

here is a copy of my path

telis is here /httpdocs/search/usr/local/morph3

after doing extraction and doing the following:

----------------

drwxrwxr-x 2 1124 utmp 4096 Mar 27 2003 config
-rw-rw-r-- 1 1124 utmp 1286 Mar 27 2003 jsapi.c
-rw-rw-r-- 1 1124 utmp 280 Mar 27 2003 jsarena.h
-rw-rw-r-- 1 1124 utmp 550 Mar 27 2003 jsdbgapi.c
-rw-rw-r-- 1 1124 utmp 755 Mar 27 2003 jsdtoa.c
-rw-rw-r-- 1 1124 utmp 9957 Mar 27 2003 jsinterp.c
-rw-rw-r-- 1 1124 utmp 10186 Mar 27 2003 js.mak
-rw-rw-r-- 1 1124 utmp 988 Mar 27 2003 jsmath.c
-rw-rw-r-- 1 1124 utmp 1014 Mar 27 2003 jsnum.c
-rw-rw-r-- 1 1124 utmp 964 Mar 27 2003 jsnum.h
-rw-rw-r-- 1 1124 utmp 838 Mar 27 2003 jsotypes.h
-rw-rw-r-- 1 1124 utmp 1479 Mar 27 2003 jstypes.h
-rw-rw-r-- 1 1124 utmp 338 Mar 27 2003 jsutil.c
-r--r--r-- 1 1124 utmp 30118 Mar 27 2003 LICENSE.html
-rw-rw-r-- 1 1124 utmp 1000 Mar 27 2003 Makefile.ref
-rw-rw-r-- 1 1124 utmp 1824 Mar 27 2003 prmjtime.c
-r--r--r-- 1 1124 utmp 3485 Mar 27 2003 README-txjs.txt
-rw-rw-r-- 1 1124 utmp 373 Mar 27 2003 rules.mk
[root@schnauber txjs]# cd
[root@schnauber root]# cd /home/httpd/vhosts/i164.com/httpdocs/search
[root@schnauber search]# ls -l
total 28352
drwxr-xr-x 2 i164bfornet psacln 4096 Sep 30 16:56 cgi-bin
-rwxr-xr-x 1 1110 utmp 76575 Sep 11 11:49 install
-rw-r--r-- 1 1110 utmp 12 Sep 11 11:49 install.sum
-rw-r--r-- 1 1110 utmp 8106 Sep 11 11:50 upgrade.txt
drwxr-xr-x 3 root root 4096 Sep 30 17:28 usr
-rw-r--r-- 1 i164bfornet psacln 10991543 Sep 30 16:39 webinator-4.3.tar.gz
-rw-r--r-- 1 1110 utmp 12 Sep 11 11:50 webinator.sum
-rw-r--r-- 1 1110 utmp 17889280 Sep 11 11:50 webinator.tar
[root@schnauber search]# gunzip <webinator-4.3.tar.gz | tar xvf -
install
install.sum
upgrade.txt
webinator.tar
webinator.sum
[root@schnauber search]# sh ./install
===============================================================================
Webinator Version 4.03 Installation v1.71
===============================================================================

Checking install script...Ok
If you already have full Texis or an older version of Webinator installed
you should read the upgrade notes.
View the upgrade notes (y/n)? [ENTER for n]:
Examining your system...done

------------------------------ NOTE: ---------------------------------
This installation should preferably be run as the user that will
actually run the software, not as root. The user should be the same
user that your web server runs CGI programs as. For this installation
you should have permission to place and move files in the install
directory and the web server tree.

You appear to be root. What (non-privileged) user will be running the
software? Webinator files will be owned and setuid to this user. Either:
o Enter the CGI user below, or
o Enter "none" to skip the chown (YOU will have to do it later), or
o Press Ctrl-C/Del to quit, and re-start install as the CGI user.

Web user [ENTER for apache]: i164bfornet

-----------------------------------------------------------------------
What directory would you like to install Webinator in? Webinator
executables and other files will be placed under here. It should be
OUTSIDE (inaccessible to) your web server tree. NOTE: This directory
should be /usr/local/morph3 unless you are unable to install there.

Install dir [ENTER for /usr/local/morph3]: /home/httpd/vhosts/i164.com/httpdocs/
search/usr/local/morph3
Checking install dir...Ok
Checking tar file...Ok
Unpacking Webinator files...Ok
Checking for existing version....Ok
Checking files...Ok
Configuring and installing Webinator files:
INFO: 2 patches made
INFO: 2 patches made
INFO: 2 patches made
Existing bin dir backed up to /home/httpd/vhosts/i164.com/httpdocs/search/usr/lo
cal/morph3/bin-old
Cleaning up temp files...done

---------------------------------------------------------------------
Where is your web server's CGI directory? This is the full path to
the file system (*not* URL) directory on this machine containing your
CGI programs. Usually this is under the top directory for the web
server. For Apache servers, it is probably the second argument to
ScriptAlias in your conf file.

This installation will install some programs (symlinks) in the CGI
directory you specify. Programs there must be executable by the web
server. The install will verify this with a web fetch.

CGI dir [ENTER for /var/www/cgi-bin]: /home/httpd/vhosts/i164.com/httpdocs/cgi-b
in
Directory /home/httpd/vhosts/i164.com/httpdocs/cgi-bin does not exist.
CGI dir [ENTER for /var/www/cgi-bin]:

should i physicall move files? if so which ones?
webmaster1650
Posts: 7
Joined: Mon Sep 29, 2003 5:09 pm

Newbie ?

Post by webmaster1650 »

and
webmaster1650
Posts: 7
Joined: Mon Sep 29, 2003 5:09 pm

Newbie ?

Post by webmaster1650 »

if needed i can give you viewable ftp access to check the directory structure?
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

Newbie ?

Post by mark »

You have to enter the existing directory that is configured in your webserver for cgi applications.

You left "search" out of the cgi path you typed.
webmaster1650
Posts: 7
Joined: Mon Sep 29, 2003 5:09 pm

Newbie ?

Post by webmaster1650 »

i am now getting a 403 error

What is the prefix for CGI URLs (the part of the URL before the program)?
o You may enter a URL, such as http://schnauber/bin
if your site uses virtual hosts or a port other than 80. The site
must reside on this machine (the one running the install).
o Or you can enter just a URL path such as /bin (assumes host above)
o Or enter /newdir to start over with a new CGI directory instead.

CGI URL prefix [ENTER for http://schnauber/bin]: http://i164.com/httpdocs/search
/usr/local/morph3/bin

--------------------------------------------------------
What is the extension for CGI URLs (the filename extension of the program)?
This may be .cgi if your CGI programs are named like "mysearch.cgi" in URLs.
Or it may be "none" if you have a dedicated CGI dir and URL instead.

CGI extension [ENTER for none]: .cgi
Checking dir with a web fetch...failed, will try again
Trying again with file...*** Failed ***
The URL http://i164.com/httpdocs/search/usr/loc ... /installte
st/func.html?-dump
could not be fetched.
Possibly the CGI URL prefix (http://i164.com/httpdocs/search/usr/local/morph3/bi
n)
or the CGI extension (.cgi) is wrong.
The web server response was: HTTP/1.1 403 Forbidden

---------------------------------------------
Post Reply