Page 1 of 1

dowalk problems

Posted: Sun Jan 18, 2004 12:46 pm
by fileformat
I'm trying to get Webinator working but am having problems with dowalk. I've tried a bunch of different settings, and have gotten errors with each:

Using my public address:
Had this error: Cannot resolve host `': Host not found

Switching the DNS to system: same error

Also switch Net mode to system:
Had this error: HttpSendRequest() to failed: ERROR_12007_317

For grins, I tried it with
With DNS=internal and net=internal
Had this error: (Can't create socket: 10106 - unknown winsock error,Cannot connect to The requested service provider could not be loaded or initialized.)

With DNS=system and net=system
Had this error: HttpSendRequest() to failed: ERROR_12029_317

My Texis -version is
Texis Web Script (Vortex) Copyright (c) 1996-2004 Thunderstone - EPI, Inc.
Free Webinator Version 4.04.1073585923 of Jan 8, 2004 (i686-intel-winnt-32-32)

I'm running on WinXP, have plenty of memory. I can see with the network address and the host name (both ping and wget). I'm running everything as an administrator.

dowalk problems

Posted: Mon Jan 19, 2004 9:47 am
by John
Is what the name you used should resolve to? The errors from Net mode system correspond to the internal. ERROR_12007_317 indicates the name could not be resolved, and ERROR_12029_317 means it could not connect.

You might also try invoking the walk from the command line in case there are permission issues via the webserver you are using.

dowalk problems

Posted: Mon Jan 19, 2004 10:58 pm
by fileformat
Running it from the command line works using the command line displayed in the web interface.

What would cause this? Are there any special path/env settings that it needs? What special permissions does it need (I'm already running as an administrator, so I'm not sure what else I can do)? Is there a debug parameter or something that will give me more information about what is failing or what it needs?

Texis seems to be working correctly as a CGI program for configuring, monitoring and searching.

dowalk problems

Posted: Tue Jan 20, 2004 10:51 am
by mark
You may be running as administrator, but the CGI program within the webserver environment doesn't. It's probably running as a very unprivileged user. It would seem that that user has no access to any network resources (like DNS and web) which are required to do a walk, but to search.

Check your webserver's config to see what user it is running CGI's as. Enable DNS and web for that user.