Solaris 10 on Opteron

Post Reply
james.thomas
Posts: 15
Joined: Tue Oct 26, 2004 12:07 pm

Solaris 10 on Opteron

Post by james.thomas »

We are currently trying to install Texis (5.0) on a new Opteron server running Solaris 10. I believe you had indicated that texis had not been tested on either Solaris 10 or the Opteron architecture, but should function properly. However, installation attempts are aborted and the following error message is given. We have run the installation both as root and user apache (apache is the owner of both the webroot and the morph3 directory) with the same result.




$ ./install
===============================================================================
Texis Version 5.00 Installation v1.86
===============================================================================

Checking install script...Ok
If you already have full Texis installed you should read the upgrade notes.
View the upgrade notes (y/n)? [ENTER for n]:
Examining your system...done

------------------------------ NOTE: ---------------------------------
This installation should preferably be run as the user that will
actually run the software, not as root. The user should be the same
user that your web server runs CGI programs as. For this installation
you should have permission to place and move files in the install
directory and the web server tree.

-----------------------------------------------------------------------
What directory would you like to install Texis in? Texis
executables and other files will be placed under here. It should be
OUTSIDE (inaccessible to) your web server tree. NOTE: This directory
should be /usr/local/morph3 unless you are unable to install there.

Install dir [ENTER for /usr/local/morph3]:
Checking install dir...Ok
Checking tar file...Ok
Unpacking Texis files...Ok
Checking files...Ok
Configuring and installing Texis files:
./install: /usr/local/morph3/install-tmp/usr/local/morph3/bin/gwpatch: cannot execute

*** Aborting installation due to above error ***




-=-=-=-=-= VERSION INFORMATION =-=-=-=-=-

$ more version
Texis Web Script (Vortex) Copyright (c) 1996-2004 Thunderstone - EPI, Inc.
Commercial Version 5.00.1086160712 20040602 (sparc-sun-solaris2.6-64-32)

$ uname -a
SunOS [xxxxxx] 5.10 s10_63 i86pc i386 i86pc

$ pwd
/usr/local
$ ls -l
total 2
drwxrwxrwx 3 apache staff 512 Dec 28 11:42 morph3
User avatar
John
Site Admin
Posts: 2605
Joined: Mon Apr 24, 2000 3:18 pm
Location: Cleveland, OH
Contact:

Solaris 10 on Opteron

Post by John »

The version you are trying to install is the Sparc version of Texis. I would think the Opteron would be more likely to be compatible with the x86 Solaris version.
John Turnbull
Thunderstone Software
Post Reply