Installation problem, CGI-Error

Post Reply
dreyer
Posts: 4
Joined: Sun May 08, 2005 12:21 pm

Installation problem, CGI-Error

Post by dreyer »

Hello,

I tried several times now to install Webinator 5.1 on my server - without success. My system is a Linux machine on Intel, uname tells me 2.4.29-grsec.

I have no root access.

When I run the setup script I get the following messages:
======================================================
Stopping monitor processes.....done
Checking dir with a web fetch...failed, will try again
Trying again with file...*** Failed ***
The URL http://www.dlp-info.de/webinator/texis/ ... html?-dump
could not be fetched.
Possibly the CGI URL prefix (http://www.dlp-info.de/webinator)
or the CGI extension (none) is wrong.
The web server response was: HTTP/1.1 404 Not Found
======================================================

I am allowed to place cgi-scripts everywhere. I have double-checked the directories, everything is OK. The installation-script does not produce anything in the directory, the directory is empty ! I set the rights to rw for everyone to test if it is because of missing rights.

I saw several entries on this board reporting a simular error but I couldn't find a solution for my problem. Could you please help me? Why is there no file or link in the directory I specified in the installation script? What am I doing wrong...?

Thanx in advance,
Ingo
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

Installation problem, CGI-Error

Post by mark »

texis is removed from the specified cgi directory if it doesn't work. Do you need to add ".cgi" or such for cgi programs? You usually do if you can place them anywhere. If so make sure you specify the proper extension when installing.
dreyer
Posts: 4
Joined: Sun May 08, 2005 12:21 pm

Installation problem, CGI-Error

Post by dreyer »

I tried with and without .cgi, both the same result. I do not need a special directory for CGI and I don't need a special extension. Of course the script must be encoded correct, for example the "#!/usr/bin/perl" at the beginning for an perl-script

Any other idea which could solve the problem?
User avatar
John
Site Admin
Posts: 2603
Joined: Mon Apr 24, 2000 3:18 pm
Location: Cleveland, OH
Contact:

Installation problem, CGI-Error

Post by John »

Setting a ScriptAlias correctly often helps. It maybe that without a proper ScriptAlias that the webserver is not searching the entire URL for the CGI program, and then setting PATH_TRANSLATED. Which webserver are you using?
John Turnbull
Thunderstone Software
dreyer
Posts: 4
Joined: Sun May 08, 2005 12:21 pm

Installation problem, CGI-Error

Post by dreyer »

I use apache and I have no access to httpd.conf. If I look to the error-log I get an message:
Premature end of script headers: /kunden/96178_71573/webseiten/webinator/texis.cgi

And if I use .cgi as extension I get error 500 instead of 404.
dreyer
Posts: 4
Joined: Sun May 08, 2005 12:21 pm

Installation problem, CGI-Error

Post by dreyer »

One more information: Wenn I copy texis by hand to the directory and call it, I get an additional information in the log:

texis.cgi: error while loading shared libraries: libtermcap.so.2: cannot open shared object file: No such file or directory
[Mon May 9 19:35:54 2005] [error] [client 84.160.113.66] Premature end of script headers: /kunden/96178_71573/webseiten/webinator/texis.cgi

In another thread you wrote, that I have to download it and set the LD_LIBRARY_PATH. I did this, because I have no root rights and I cannot put it to the the common lib-directories. Before doing this I wasn't able to run the install-script so far.

BTW: When I call "texis" from the bin-directory from the shell I don't get any error-message. It seems to work - It prints the help message to the screen.

What can I do to solve this ?
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

Installation problem, CGI-Error

Post by mark »

Sounds like the environment where your webserver runs cgi programs is restricted and doesn't have the full complement of system libraries that your interactive shell environment does. You might have to ask your service provider about that.
Post Reply