017 [webinatoradmin](dowalk) 915: Can't fork: Cannot allocate memory in the function TXpopenduplex

Post Reply
harold
Posts: 35
Joined: Tue Aug 15, 2000 12:52 am

017 [webinatoradmin](dowalk) 915: Can't fork: Cannot allocate memory in the function TXpopenduplex

Post by harold »

I've been running Webinator 4.3-Unix-w/plugin for many years, migrating it from server to server. I've now got it on a Centos 6 system, and I get the error in the subject when a walk is started or if I try to delete a profile. Top shows lots of memory still available. But, if I try to start another application from the command line, I also get a cannot allocate memory error. I have to reboot to recover.

Here's what top shows:

top - 19:53:36 up 11 min, 1 user, load average: 0.00, 0.10, 0.08
Tasks: 628 total, 1 running, 29 sleeping, 0 stopped, 598 zombie
Cpu(s): 0.7%us, 0.2%sy, 0.0%ni, 99.1%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 12582912k total, 210496k used, 12372416k free, 0k buffers
Swap: 0k total, 0k used, 0k free, 34276k cached
Write failed: Success
NaCl plugin exited with status code 255. %CPU %MEM TIME+ COMMAND
(R)econnect, (C)hoose another connection, or E(x)it? 2:13.76 texis.cgi
1797 apache 20 0 10920 4008 1592 S 1.3 0.0 0:05.17 texis
946 root 20 0 15424 1764 988 R 0.7 0.0 0:03.99 top
886 mysql 20 0 368m 19m 5036 S 0.3 0.2 0:00.33 mysqld
1 root 20 0 19236 1464 1220 S 0.0 0.0 0:00.02 init
2 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kthreadd/835023
3 root 20 0 0 0 0 S 0.0 0.0 0:00.00 khelper/8350232
137 root 16 -4 10644 680 408 S 0.0 0.0 0:00.00 udevd
628 root 20 0 179m 1448 1052 S 0.0 0.0 0:00.01 rsyslogd
642 dbus 20 0 21436 888 640 S 0.0 0.0 0:00.00 dbus-daemon
664 root 20 0 66228 1264 556 S 0.0 0.0 0:00.02 sshd
674 root 20 0 21720 948 712 S 0.0 0.0 0:00.00 xinetd
685 root 20 0 66412 964 320 S 0.0 0.0 0:00.00 saslauthd
686 root 20 0 66412 692 48 S 0.0 0.0 0:00.00 saslauthd
706 root 20 0 82648 2504 804 S 0.0 0.0 0:00.01 sendmail
715 smmsp 20 0 78228 2096 640 S 0.0 0.0 0:00.00 sendmail
726 root 20 0 272m 10m 5676 S 0.0 0.1 0:00.05 httpd
733 apache 20 0 379m 20m 4464 S 0.0 0.2 0:30.07 httpd
738 root 20 0 114m 1212 608 S 0.0 0.0 0:00.00 crond
784 root 20 0 105m 1568 1312 S 0.0 0.0 0:00.02 mysqld_safe
919 root 20 0 19268 796 536 S 0.0 0.0 0:00.00 dovecot
920 dovecot 20 0 12988 1052 860 S 0.0 0.0 0:00.00 anvil
922 root 20 0 13116 1148 860 S 0.0 0.0 0:00.00 log
924 root 20 0 15092 3208 956 S 0.0 0.0 0:00.00 config
927 root 20 0 98388 4788 3776 S 0.0 0.0 0:00.13 sshd
931 root 20 0 105m 1916 1496 S 0.0 0.0 0:00.01 bash
950 apache 20 0 8572 1148 868 S 0.0 0.0 0:00.01 monitor
952 apache 20 0 292m 28m 4260 S 0.0 0.2 0:00.92 httpd
958 apache 20 0 287m 21m 4268 S 0.0 0.2 0:00.27 httpd
959 apache 20 0 376m 18m 3380 S 0.0 0.2 0:00.18 httpd
974 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
975 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
976 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
978 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
979 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
980 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
983 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
984 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
985 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
987 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
988 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
989 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
990 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
992 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>
993 apache 20 0 0 0 0 Z 0.0 0.0 0:00.00 texis <defunct>

Any ideas what I'm doing wrong?

THANKS for the great product!

Harold
User avatar
John
Site Admin
Posts: 2603
Joined: Mon Apr 24, 2000 3:18 pm
Location: Cleveland, OH
Contact:

017 [webinatoradmin](dowalk) 915: Can't fork: Cannot allocate memory in the function TXpopenduplex

Post by John »

The 598 zombie processes are the problem. If you do a "ps axf" you should see the parent of those processes, which may give a clue, as the parent is not cleaning up properly.
John Turnbull
Thunderstone Software
harold
Posts: 35
Joined: Tue Aug 15, 2000 12:52 am

017 [webinatoradmin](dowalk) 915: Can't fork: Cannot allocate memory in the function TXpopenduplex

Post by harold »

THANKS! Once I try to start a walk, ps can't allocate memory. Here's a ps axf from before the walk attempt followed by a ps axf after a walk attempt.

THANKS!

Harold

[root@mai ~]# ps axf
PID TTY STAT TIME COMMAND
1 ? Ss 0:00 init
2 ? S 0:00 [kthreadd/835023]
3 ? S 0:00 \_ [khelper/8350232]
137 ? S<s 0:00 /sbin/udevd -d
624 ? Sl 0:00 /sbin/rsyslogd -i /var/run/syslogd.pid -c 5
638 ? Ss 0:00 dbus-daemon --system
660 ? Ss 0:00 /usr/sbin/sshd
939 ? Ss 0:00 \_ sshd: root@pts/0
941 pts/0 Ss 0:00 \_ -bash
966 pts/0 R+ 0:00 \_ ps axf
670 ? Ss 0:00 xinetd -stayalive -pidfile /var/run/xinetd.pid
681 ? Ss 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam -n 2
682 ? S 0:00 \_ /usr/sbin/saslauthd -m /var/run/saslauthd -a pam -n 2
702 ? Ss 0:00 sendmail: accepting connections
711 ? Ss 0:00 sendmail: Queue runner@01:00:00 for /var/spool/clientmqueue
722 ? Ss 0:00 /usr/sbin/httpd
925 ? S 0:00 \_ /usr/sbin/httpd
926 ? S 0:00 \_ /usr/sbin/httpd
927 ? S 0:00 \_ /usr/sbin/httpd
928 ? S 0:00 \_ /usr/sbin/httpd
929 ? S 0:00 \_ /usr/sbin/httpd
734 ? Ss 0:00 crond
780 ? S 0:00 /bin/sh /usr/bin/mysqld_safe --datadir=/var/lib/mysql --socket=/var/lib/mysql/mysql.sock --pid-file=/var/run/mysqld/mysqld.pid --basedir=/usr --user=mysql
882 ? Sl 0:00 \_ /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --log-error=/var/log/mysqld.log --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/lib/mysql/mysql.sock
915 ? Ss 0:00 /usr/sbin/dovecot
916 ? S 0:00 \_ dovecot/anvil
918 ? S 0:00 \_ dovecot/log
958 ? S 0:00 monitor (Texis)
960 ? S 0:00 monitor -d /usr/local/morph3/texis/testdb/ -z
963 ? S 0:00 monitor -d /usr/local/morph3/texis/2016Rules/db1/ -z
[root@mai ~]# ps axf
-bash: fork: Cannot allocate memory
User avatar
mark
Site Admin
Posts: 5518
Joined: Tue Apr 25, 2000 6:56 pm

017 [webinatoradmin](dowalk) 915: Can't fork: Cannot allocate memory in the function TXpopenduplex

Post by mark »

Check the walk status file(s) /usr/local/morph3/texis/2016Rules/db*.long and the vortex.log to see if anything illustrative is logged about the profile startup.

Also, what's the memory situation, reported by "free", of the machine before starting the walk?

ps auxf will provide more info about parents and process sizes etc.
harold
Posts: 35
Joined: Tue Aug 15, 2000 12:52 am

017 [webinatoradmin](dowalk) 915: Can't fork: Cannot allocate memory in the function TXpopenduplex

Post by harold »

OK, it looks like I tried to get to fancy in the migration to the new server. vortex.log showed it could not find public_html/webinator/dowalk . I had moved it. So, I moved it back and copied all of morph3 back from my old server. It all works now! It was pretty exciting for a while there when the system would just take off and consume all resources.

Thanks for the help!

Harold
Post Reply