Upgrade Webinator 6 to TLSv1.2

Post Reply
rjshelq
Posts: 75
Joined: Thu Nov 17, 2005 3:25 pm

Upgrade Webinator 6 to TLSv1.2

Post by rjshelq »

I'm currently using Webinator Version 6.01.1325780201 20120105 (x86_64-unknown-linux2.6.9-64-64), and it continues to provide excellent service with the exception of the lack of support for TLSv1.2 during site walking and during use of the admin panel.

Is there any patch, or a module from a newer version of Webinator, which would update this old version to provide support for TLSv1.2 for site walking and admin panel connection?

I don't need any new features, and would therefore prefer to avoid installing an entirely new version of Webinator (with the attendant learning curve and changes) just to get TLSv1.2, if at all possible.

At present, I'm allowing my server to connect using TLSv1.0 for site walks, and using Firefox 52 esr (the last version which supported TLSv1.0) to access the admin panel. But It would certainly be nice to avoid needing such work arounds.
User avatar
mark
Site Admin
Posts: 5519
Joined: Tue Apr 25, 2000 6:56 pm

Upgrade Webinator 6 to TLSv1.2

Post by mark »

The only way to get tlsv1.2 direct support is to upgrade. For the admin interface you could access Webinator through your own web server as long as is supports CGI.
User avatar
John
Site Admin
Posts: 2605
Joined: Mon Apr 24, 2000 3:18 pm
Location: Cleveland, OH
Contact:

Upgrade Webinator 6 to TLSv1.2

Post by John »

The version you are using is close to 9 years old, and as Mark said you can't do partial upgrades, and the best plan is to upgrade Webinator to the latest version. While there are changes it should not be completely unfamiliar.

The other approach that would work, at least for a while, would be to run a proxy server that will talk TLSv1.0 to Webinator, and TLSv1.2 to your webserver, but I think that is more effort to setup than upgrading Webinator.
John Turnbull
Thunderstone Software
Post Reply